본문 바로가기
IT/네트워크

[라우터] EIGRP 네임드 설정

by JGSHIN 2025. 2. 16.
SMALL

## EIGRP 네임드 모드는 AS 번호를 사용하지 않고 'router eigrp myname' 같이 이름을 사용한다.

 

## 와이드 메트릭을 사용하여 1Gbps 보다 빠른 고속 링크에서도 정확한 경로 선택을 있다.

## IOS 대역폭이 1Gbps 이상이 되는 인터페이스의 delay 값을 모두 동일하게 여여긴다.

    결과적으로 고속의 링크를 가진 네트워크에서 기존의 EIGRP 최적 경로 선택을 제대로 없다.

 

## EIGRP 네임드 모드는 자동으로 와이드 메트릭이라는 64비트 길이의 새로운 메트릭 계산식을 사용하므로 고속 링크로 구성된 네트워크에서도 최적의 경로를 선택할 있다.

 

 

## EIGRP 네임드 설정

 

R1(config)# router eigrp myEigrp

R1(config-router)# address-family ipv4 unicast autonomous-system 1

R1(config-router-af)# network 1.1.1.1 0.0.0.0

R1(config-router-af)# network 1.1.12.1 0.0.0.0

R1(config-router-af)# network 1.1.13.1 0.0.0.0

 

## EIGRP 설정모드에서 'address-family' ipv4 또는 ipv6 옵션을 사용할 있다.

 

## EIGRP 인증은 네이버 사이에 메시지를 주고 받으면서 MD5 또는 HMAC-SHA-256 방식으로 인증 있다.

## R1 - R2 HMAC-SHA-256으로 EIGRP 인증 설정

 

R1(config)#router eigrp myEigrp

R1(config-router)#address-family ipv4 unicast autonomous-system 1

 

R1(config-router-af)#af-interface f0/0.12

R1(config-router-af-interface)#authentication mode hmac-sha-256 7 cisco123

 

R2(config)#router eigrp myEigrp

R2(config-router)#address-family ipv4 unicast autonomous-system 1

 

R2(config-router-af)#af-interface f0/0.12

R2(config-router-af-interface)#authentication mode hmac-sha-256 7 cisco123

 

## R1 - R3 인증

 

R1(config)#key chain EIGRP-KEY

R1(config-keychain)#key 1

R1(config-keychain-key)#key-string cisco123

R1(config-keychain-key)#exit

R1(config-keychain)#exit

 

R1(config)#router eigrp myEigrp

R1(config-router)#address-family ipv4 unicast autonomous-system 1

 

R1(config-router-af)#af-interface f0/0.13

R1(config-router-af-interface)#authentication mode md5

R1(config-router-af-interface)#authentication key-chain EIGRP-KEY

 

R3(config)#key chain EIGRP-KEY

R3(config-keychain)#key 1

R3(config-keychain-key)#key-string cisco123

R3(config-keychain-key)#exit

R3(config-keychain)#exit

 

R3(config)#router eigrp myEigrp

R3(config-router)#address-family ipv4 unicast autonomous-system 1

 

R3(config-router-af)#af-interface f0/0.13

R3(config-router-af-interface)#authentication mode md5

R3(config-router-af-interface)#authentication key-chain EIGRP-KEY

 

 

## EIGRP 패킷 대역폭 지정 ( 디폴트 50% )

 

R1(config)#router eigrp myEigrp

 

R1(config-router)#address-family ipv4 unicast autonomous-system 1

 

R1(config-router-af)#af-interface f0/0.12

 

R1(config-router-af-interface)#bandwidth-percent 70

 

## EIGRP Hello 패킷 전송 주기나 Hold 타임 변경

 

R1(config)#router eigrp myEigrp

R1(config-router)#address-family ipv4 unicast autonomous-system 1

 

R1(config-router-af)#af-interface f0/0.12

R1(config-router-af-interface)#hello-interval 3

R1(config-router-af-interface)#hold-time 9

 

## 수동 서머리제이션 축약

 

R2(config)#router eigrp myEigrp

R2(config-router)#address-family ipv4 unicast autonomous-system 1

 

R2(config-router-af)#af-interface f0/0.24

R2(config-router-af-interface)#summary-address 1.1.10.0/23

 

## EIGRP 스텁 모드와 태깅 설정

## 스텁 라우터는 자신에게 직접 접속된 네트워크와 축약 정보만을 네이버에게 전송한다.

## 네이버는 스텁 라우터에게 어떤 쿼리 패킷도 전송하지 않는다.

 

 

## R4(스텁모드) -> R5

 

R4(config)#router eigrp myEigrp

R4(config-router)#address-family ipv4 unicast autonomous-system 1

R4(config-router-af)#eigrp stub

 

R4(config-router-af)#af-interface f0/0.24

R4(config-router-af-interface)#summary-address 1.1.50.0 255.255.254.0

 

 

R4(config-router-af-interface)#af-interface s2/2

R4(config-router-af-interface)#summary-address 1.1.50.0 255.255.254.0

 

## R5에게서 광고받은 1.1.5.0/24 네트워크는 스텁 라우터인 R4 네이버인 R2에게 광고하지 않는다.

 

R2#show ip route 1.1.5.0

% Subnet not in table

 

 

## 'connected' 축약 네트워크가 아닌 중에서 추가적으로 특정 네트워크를 광고하려면 다음과 같이 설정한다.

 

R4(config)#ip prefix-list SendThisNetwork permit 1.1.5.0/24              ## 'prefix-list' 명령어를 사용하여 네트워크를 지정한다.

 

R4(config)#route-map SendThisNetwork                                    ## 'route-map'에서 match 명령어로 프리픽스 리스트를 호출한다.

R4(config-route-map)#match ip address prefix-list SendThisNetwork

R4(config-route-map)#exit

 

R4(config)#router eigrp myEigrp

R4(config-router)#address-family ipv4 unicast autonomous-system 1

R4(config-router-af)#eigrp stub leak-map SendThisNetwork              ## 'eigrp stub leak-map' 명령어를 사용하여 앞서 만든 루트 맵을 지정한다.

 

## 그러면 R5에게서 광고받은 1.1.5.0/24 네트워크를 스텁 라우터인 R4 네이버인 R2에게 광고한다.

 

 

 

## 태그 설정

## EIGRP 설정모드에서 별도의 루트 맵을 사용하지 않고 대그를 붙일 있다.

 

R4(config)# route-tag notation dotted-decimal

 

 

R4(config)# router eigrp myEigrp                                               ## 기본적으로는 태그 값이 32비트 값을 가진 하나의 수로 표시되어 불편하다. 명령어로 태그 값이 IP 주소의 형식으로 표시 한다.

R4(config-router)# address-family ipv4 unicast autonomous-system 1

R4(config-router-af)# eigrp default-route-tag 1.1.4.4                        ## R4 접속된 네트워크에 1.1.4.4라는 태그를 붙인다.

 

 

## R1에서 'show ip route tag 1.1.4.4' 명령어를 사용하면 태그 값이 1.1.4.4 경로를 모두 보여준다.

 

 

## 디스턴스 설정 ( AD 값으로 내부 EIGRP 네트워크의 디스턴스 값은 90이고, 외부 네트워크는 170이다. )

 

R4(config)#router eigrp myEigrp

R4(config-router)#address-family ipv4 unicast autonomous-system 1

 

R4(config-router-af)#topology base

R4(config-router-af-topology)#distance eigrp 100 105                            ## 내부 100 / 외부 105

 

 

## 특정 라우터(R5)에게서 광고 받은 특정 네트워크의 디스턴스 값을 변경하는 방법

 

R4(config)#ip access-list standard R5-LOOPBACK0                                ## 디스턴스 값을 조정하려는 특정 네트워크를 액세스 리스트로 지정한다.

R4(config-std-nacl)#permit 1.1.5.0 0.0.0.255        

R4(config-std-nacl)#exit

 

R4(config)#router eigrp myEigrp

R4(config-router)#address-family ipv4 unicast autonomous-system 1

 

R4(config-router-af)#topology base

R4(config-router-af-topology)#distance 70 1.1.45.5 0.0.0.0 R5-LOOPBACK0

 

##

70 : distance 명령어 다음에 디스턴스 값을 지정한다.

1.1.45.5 : 네트워크 광고의 출발지 주소를 지정한다.

0.0.0.0 : 와일드 카드를 지정한다. 만약, EIGRP 광고의 출발지 주소가 1.1.45.0/24 라우터를 모두 지정하려면 1.1.45.0 0.0.0.255 하면 된다.

R5-LOOPBACK0 : 앞서 만든 엑세스 리스트를 지정한다.

##

 

## 디스턴스 값은 설정한 라우터에서만 적용된다. , 다른 라우터로 변경된 디스턴스 값을 광고하지 않는다.

 

## 특정 네트워크에 대한 광고를 차단하려면 'distribute-list' 명령어를 사용한다.

 

R3(config)#ip prefix-list R4-LOOPBACK deny 1.1.4.0/24                            ## 1.1.4.0/24 네트워크를 차단하는 프리픽스 리스트를 만든다.

R3(config)#ip prefix-list R4-LOOPBACK permit 0.0.0.0/0 le 32                     ## 나머지 네트워크는 모두 허용한다.

 

R3(config)#router eigrp myEigrp

R3(config-router)#address-family ipv4 unicast autonomous-system 1

 

R3(config-router-af)#topology base

R3(config-router-af-topology)#distribute-list prefix R4-LOOPBACK in f0/0.13   ## 앞서 만든 프리픽스 리스트를 적용한다.

 

## 'distribute-list' 명령어 다음에 프리픽스 리스트 뿐만 아니라 액세스 리스트, 루트 등을 사용하여 특정 네트워크를 차단할 수도 있다.

 

 

## 설정 R3 라우팅 테이블을 확인해 보면 다음과 같이 R1(1.1.13.1)에서 광고하는 1.1.4.0/24 네트워크가 차단되고 대신 R4(1.1.34.4) 광고하는 것이 인스톨 된다.

 

## EIGRP 부하분산 R1-R2 2개의 링크로 연결되어 있지만 F0/0.12 속도가 빠르고 지연도 적어서 라우팅 테이블에 F0/0.12 인터페이스를 통한 경로만 인스톨 된다.

 

 

R1(config)#router eigrp myEigrp

R1(config-router)#address-family ipv4 unicast autonomous-system 1

 

R1(config-router-af)#topology base

R1(config-router-af-topology)#variance 128                                 ## VARIANCE 128 경로 중에서 메트릭 값이 최적 메트릭 * 128 이내이면 해당 경로를 라우팅 테이블에 인스톨 시키라는

 

 

 

 

## 'address-family ipv4 unicast autonomous-system 1' 설정 옵션

 

 

  1. 'af-interface' 설정 옵션

 

 

  authentication  authentication subcommands

  EIGRP 패킷 인증을 설정한다.

 

  bandwidth-percent   Set percentage of bandwidth percentage limit

  EIGRP 사용할 있는 대역폭을 지정한다.

 

  bfd                 Enable Bidirectional Forwarding Detection

  BFD(Bidirectional Forwarding Detection) 활성화 시킨다.

 

  dampening-change    Percent interface metric must change to cause update

  댐프닝(dampening) 관련 설정을 한다.

 

  dampening-interval  Time in seconds to check interface metrics

  댐프닝 주기를 설정한다.

 

  default             Set a command to its defaults

  exit-af-interface   Exit from Address Family Interface configuration mode

 

  hello-interval      Configures hello interval

  헬로 주기를 설정한다.

 

  hold-time           Configures hold time

  홀드 타임을 설정한다.

 

  next-hop-self       Configures EIGRP next-hop-self

  EIGRP 네트워크를 광고할 넥스트 IP 주소를 자신의 것으로 바꾸거나 또는 변경하지 않도록 설정한다.

 

  no                  Negate a command or set its defaults

 

  passive-interface   Suppress address updates on an interface

  passive-interface 기능을 설정한다. 기능을 설정하면 EIGRP 해당 인터페이스로 헬로를 전송하지 않으며, 수신도 하지 않아 네이버가 맺어지지 않는다.

 

  shutdown            Disable Address-Family on interface

  해당 인터페이스에 eigrp 동작시키지 않는다.

 

  split-horizon       Perform split horizon

  스플릿 호라이즌 기능을 활성화 또는 비활성화시킨다.

 

  summary-address     Perform address summarization

  축약 기능을 설정한다.

 

 

  1. 'eigrp' 설정 옵션

 

 

  default-route-tag      Default Route Tag for the Internal Routes

  모든 EIGRP 내부 경로에 태그를 설정할 있다.

 

  log-neighbor-changes   Enable/Disable EIGRP neighbor logging

  EIGRP 네이버 관련 로깅을 활성화 또는 비활성화시킨다.

 

  log-neighbor-warnings  Enable/Disable EIGRP neighbor warnings

  EIGRP 네이버 관련 경로 메시지 간격을 단위로 지정할 있다.

 

  router-id              router id for this EIGRP process

  EIGRP 라이터 ID IP 주소 형식으로 표시한다.

 

  stub                   Set address-family in stubbed mode

  EIGRP 스텁(stub) 에어리어 관련 설정을 한다.

 

 

  1. 'maximum-prefix' 설정 옵션 네이버에게서 수신할 있는 최대 네트워크 수와 이를 초과했을 취할 있는 동작을 지정할 있다.

 

 

  <1-100>        Threshold value (%) at which to generate a warning message

  dampened       Exponentially increase restart time interval

  reset-time     Duration after which restart history is cleared

  restart        Duration for which a prefix source is ignored

  restart-count  Number of times sessions are auto-restarted

  warning-only   Only give warning message when limit is exceeded

  <cr>

 

  1. 'metric' EIGRP 메트릭 계산시 사용하는 K 상수의 등을 설정할 있다.

 

 

  rib-scale  set scaling value for rib installation

  weights    Modify address-family metric coefficients

 

  1. 'neighbor'  EIGRP 네이버 주소를 지정하거나, 모든 네이버에게서 수신 가능한 네트워크의 수량을 지정할 있다.

 

 

  A.B.C.D         Neighbor address

  maximum-prefix  Maximum number of prefixs acceptable from all neighbors

 

  1. 'network' 명령어는 전통적인 EIGRP network 명령어와 동일하다.

, EIGRP 활성화 시킬 인터페이스의 주소를 지정한다.

 

  1. 'suhtdown' 명령어는 EIGRP 일시적으로 비활성화시킬 사용한다.

 

  1. 'timers' 명령어는 설정 변경 등으로 인하여 EIGRP 자동으로 다시 동작할 남아있는 EIGRP경로를 제거하는 시간을 지정한다.

 

 

  1. 'topology' 명령어는 다음과 같이 재분배, 부하 분산 등과 관련된 내용을 설정할 있다.

 

 

  auto-summary         Enable automatic network number summarization

  'auto-summary' 명령어를 자동 축약을 활성화 또는 비활성화시킨다.

 

  default              Set a command to its defaults

 

  default-information  Control distribution of default information

  디폴트 루트 광고의 '수신을 제어한다.

 

  default-metric       Set metric of redistributed routes

  재분배된 경로의 기본 EIGRP 메트릭 값을 지정한다.

 

  distance             Define an administrative distance

  EIGRP 경로의 AD 값을 조정한다.

 

  distribute-list      Filter entries in eigrp updates

  'distribute-list' 명령어는 EIGRP 경로 광고의 '수신을 제어한다.

 

  eigrp                EIGRP specific commands

  EIGRP 로그 저장 수량을 지정한다.

 

  exit-af-topology     Exit from Address Family Topology configuration mode

  fast-reroute         Configure Fast-Reroute

 

  maximum-paths        Forward packets over multiple paths

  1에서 32 사이의 최대 부하분산 경로의 수를 지정한다.

 

  metric               Modify metrics and parameters for advertisement

  'metric' 명령어는 1에서 255 사이의 최대 카운트 수를 지정한다.

 

  no                   Negate a command or set its defaults

  offset-list          Add or subtract offset from EIGRP metrics

 

  redistribute         Redistribute IPv4 routes from another routing protocol

  'redistribute' 다른 라우팅 프로토콜을 EIGRP 재분배할 사용한다.

 

  snmp                 Modify snmp parameters

 

  summary-metric       Specify summary to apply metric/filtering

  'summary-metric' 축약 네트워크의 메트릭 값이나 디스턴스 값을 지정한다.

 

  timers               Adjust topology specific timers

  'timers' EIGRP 경로가 액티브 상태에 머물수 있는 시간을 표시한다.

 

  traffic-share        How to compute traffic share over alternate paths

  'traffic-share' 부하 분산 방식을 지정한다.

 

  variance             Control load balancing variance

  'variance' 부하 분산시킬 경로의 메트릭 범위를 지정한다.

 

 

LIST

'IT > 네트워크' 카테고리의 다른 글

[라우터] 스태틱 라우팅  (0) 2025.02.16
[라우터] EIGRP 라우팅  (0) 2025.02.16
[라우터] OSPF 라우팅  (0) 2025.02.16
[라우터] OSPF 인증 보안 설정  (0) 2025.02.16
[라우터] IS-IS 라우팅  (0) 2025.02.16
📧 이메일 문의
by @ 2025 JGSHIN