본문 바로가기
IT/네트워크

[라우터]MHSRP 구성(VLAN)

by JGSHIN 2025. 2. 16.
SMALL

 

# 라우터에 HSRP 구성 이후

# VLAN 10, 20 따라 라우트1 VLAN10 라우터2 VLAN20 대한 엑티브를 설정하여 흐름제어

 

 

 

R1(confing)# interface fastethernet 0/0

R1(confing-if)# no shutdown

R1(confing-if)# exit

 

R1(confing)# interface fastethernet 0/0.1                                     # 서브 인터페이스 활성화

R1(confing-subif)# encapsulation dot1q 10                      # 그룹 10 지정

R1(confing-subif)# ip address 11.1.1.2 255.255.255.0          # 서브 인터페이스(게이트웨이) IP 부여

R1(confing-subif)# standby 10 ip 11.1.1.1                                     # 그룹 10 VIP

R1(confing-subif)# standby 10 priority 150                                   # 150 수치가 높은것이 액티브

R1(confing-subif)# standby 10 preempt                          # R1 살아날때 백페일오버 기능 // 다시 그룹 10 대한 엑티브 권한을 가져옴

R1(confing-subif)# exit

 

R1(confing)# interface fastethernet 0/0.2                       # 서브 인터페이스 활성화

R1(confing-subif)# encapsulation dot1q 20                     # 그룹 20 지정

R1(confing-subif)# ip address 22.2.2.2 255.255.255.0          # 서브 인터페이스(게이트웨이) IP 부여

R1(confing-subif)# standby 20 ip 22.2.2.1                       # 그룹 20 VIP

R1(confing-subif)# standby 20 priority 50                                    # 50 수치가 낮은것이 스탠바이

 

R2(confing)# interface fastethernet 0/0

R2(confing-if)# no shutdown

R2(confing-if)# exit

 

R2(confing)# interface fastethernet 0/0.1

R2(confing-subif)# encapsulation dot1q 10

R2(confing-subif)# ip address 11.1.1.2 255.255.255.0

R2(confing-subif)# standby 10 ip 11.1.1.1

R2(confing-subif)# standby 10 priority 50

R2(confing-subif)# exit

 

R2(confing)# interface fastethernet 0/0.2

R2(confing-subif)# encapsulation dot1q 20

R2(confing-subif)# ip address 22.2.2.2 255.255.255.0

R2(confing-subif)# standby 20 ip 22.2.2.1

R2(confing-subif)# standby 20 priority 150

R2(confing-subif)# standby 20 preempt

 

 

# MHSRP 구성 확인

R1# show standby brief

R2# show standby brief

 

 

## HSRP 타이머 튜닝

## 라우터 다운시 라우팅 테이블을 만들어야 하기에 딜레이가 발생 디폴트 헬로와 홀드 타이머가 3초와 10초다.

 

R1(confing)# interface fastethernet 0/0

R1(confing-if)# no shutdown

R1(confing-if)# exit

 

R1(confing)# interface fastethernet 0/0.1                                    

R1(confing-subif)# encapsulation dot1q 10                     

R1(confing-subif)# ip address 11.1.1.2 255.255.255.0         

R1(confing-subif)# standby 10 ip 11.1.1.1                                    

R1(confing-subif)# standby 10 priority 150                                  

R1(confing-subif)# standby 10 preempt delay 10             # R1 살아날때 백페일오버 기능 // 다시 그룹 10 대한 엑티브 권한을 10 유예 이후 가져옴

R1(confing-subif)# standby 10 timers msec 250 msec 750    # HSRP Hello, hold 컨버전스 타임을 줄여줌

R1(confing-subif)# exit

 

R1(confing)# interface fastethernet 0/0.2                      

R1(confing-subif)# encapsulation dot1q 20                    

R1(confing-subif)# ip address 22.2.2.2 255.255.255.0          

R1(confing-subif)# standby 20 ip 22.2.2.1                       

R1(confing-subif)# standby 20 priority 50                                    

R1(confing-subif)# standby 20 timers msec 250 msec 750       # HSRP Hello, hold 컨버전스 타임을 줄여줌

 

R2(confing)# interface fastethernet 0/0

R2(confing-if)# no shutdown

R2(confing-if)# exit

 

R2(confing)# interface fastethernet 0/0.1

R2(confing-subif)# encapsulation dot1q 10

R2(confing-subif)# ip address 11.1.1.2 255.255.255.0

R2(confing-subif)# standby 10 ip 11.1.1.1

R2(confing-subif)# standby 10 priority 50

R2(confing-subif)# standby 10 timers msec 250 msec 750

R2(confing-subif)# exit

 

R2(confing)# interface fastethernet 0/0.2

R2(confing-subif)# encapsulation dot1q 20

R2(confing-subif)# ip address 22.2.2.2 255.255.255.0

R2(confing-subif)# standby 20 ip 22.2.2.1

R2(confing-subif)# standby 20 priority 150

R2(confing-subif)# standby 20 preempt delay 10

R2(confing-subif)# standby 20 timers msec 250 meec 750

 

 

## HSRP VLAN10 대한 엑티브는 살아 있지만 Fa 0/1 가는 라인이 죽었을 경우 그림과 같이 다시 돌아 나오는 불합리한 경로가 생긴다.

## 프라이어리티를 낮추어 Actrive 라우터와 Standby 라우터의 위치를 바꿔준다.

 

 

 

R1(confing-subif)# standby 10 priority 150                                      # R1 VLAN10 엑티브 프라이어티 150

R1(confing-subif)# standby 10 preempt delay 10

R1(confing-subif)# standby 10 track fastethernet 0/1 60        # R1 0/1 경로가 다운시 60 만큼 내려 VLAN10 엑티브 프라이어티 90으로 내린다.

 

R2(confing-subif)# standby 10 priority 100                       # R2 VLAN10 스탠바이 프라이어티 50 100으로 올려 액티브로 바꿔준다.

 

 

LIST

'IT > 네트워크' 카테고리의 다른 글

[라우터] BGP 라우팅 +RIP  (0) 2025.02.16
[라우터] RIP 라우팅  (0) 2025.02.16
[라우터]HSRP 구성  (0) 2025.02.16
[라우터] 프레임 릴레이 DCE 설정  (0) 2025.02.16
[스위치]RSTP 루트스위치 선정  (0) 2025.02.16
📧 이메일 문의
by @ 2025 JGSHIN